more /root/Help/Out Of Memory Error.thread
2008-10-05 23:02:42MrJackSparrow2
What parameter would I pass to LGM to disable the 95mb limit, or at least raise the memory limit?
2008-10-06 03:50:13IsmAvatar
-Xms<size> Initial heap
-Xmx<size> Maximum heap

Replace <size> with the size, followed by M for MB, G for GB. The defaults for these are usually 64M, but of course the program will use other memory for other purposes, such as instructions and variables, thus the additional 31MB.

For example:
-Xms200M -Xmx200M
would allow approximately 200 MB both initially and as a maximum.

Generally, you should keep Xms low, so that you're not allocating more memory than needed. In this respect, it would probably be acceptable to just allow the default value by not specifying the option. Unless of course you know that you're going to be using a lot of memory.

Xmx on the other hand should be higher, so that the memory can be expanded. Just be aware that the more you allow, the less other programs can use.

How much memory you use varies, but for large files such as 5 MB or larger, you may wish to allow more memory than the default 64M.
2008-10-06 22:40:07MrJackSparrow2
Amazing as usual IsmAvatar! Thanks a ton!